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This document covers:

Downloading and installing a copy of powerTWO
Picking up updates

Starting a new design

Importing an existing design

Editing a design

Saving and testing (downloading) a design
Updating the powerONE bios



Downloading and installing a copy of powerTWO

powerTWO has been qualified to run under Windows XP, Windows Vista and Windows 7. If you
don’t have any of those available, it’s time to acquire one or pack up the unit. The following are the
Windows XP interactions.

Visit http://www.emspace.com, select QuickStart and download powerfTWO. You will then see:

File Download - Security Warning

Do you want to run or zave this file?

Mame: ESIpowerTWOSetup_1.1.0.107.msi
Type: Windows Inskaller Package, 3.71ME

From: wwWW.emspace.com

Eiun ][ Save ]| Cancel |

l--’ \hl While files frorm the Internet can be uzetul, this file type can
\ ﬁ potentially harm your computer. [ pou do nat trust the source, do nat
- rur or gave this software, wWhat's the righ?

Click Run.

Open File - Security Warning

Do you want to run this file?

Mame: ESIpower TWOSEtup, msi
Fublizher: Embedded Spaces Inc
Type: Windows Installer Package

From: C:i\Documents and Settings) JosefiMy Documents), ..

Bun ]| Cancel |

Alwayz ask before opening this file

YWhile files from the Internet can be useful, thiz file type can
@ potentially karm your computer. Only run zoftware from publizhers
wou trust, What's the rigk?

Click Run again.
This will start the powerTWO Setup Wizard.


http://www.emspace.com/

EoX

Welcome to the powerTW0O Setup Wizard . ES’

The inztaller will guide you through the steps required to install powerT'W0 on pour compter.

WARMIMG: Thiz computer program iz protected by copyright law and intemnational treaties.
Unauthorized duplication or distribution of this pragram, or any portion of it, may result in severe civil

or criminal penalties, and will be prozecuted to the maximum extent pozzible under the law. [c]
2007-2009 Embedded Spaces Inc

Cancel

Click Next.

5 power TWO

Select Installation Folder . ES’

The ingtaller will install powerTW0 to the following folder.

Toinstall i thiz folder, click "Mext". Tainstal to a different folder, enter it below or click "Browse".

Folder:
C:%Proagram Filez\E mbedded Spaces Inchpower W0 [ Browsze. .. ]
| DiskCost. |
Inztall powerT'w0 for yourself, or for anyone who uses this computer:
) Evervane
@ iustme
[ Cancel ] ’ < Back ] I Mest » ]

Click Next and Next at the next two windows. This will place powerTWO in

C:\Program Files\ Embedded Spaces Inc\powerTTWO\, and it will create an application data directory to
store powerONE device descriptions.

For Win7 the top directory will be Program Files (X86).




Create a directory for your designs, for instance a folder in your laptop called P2_pox, and copy any
design files (.pox) you have, into it. Ask customer support for some relevant samples if you have

none.

Now start up powerTWO. It will locate the latest version of powerTWO and suggest that you load
it. < powerTWO update is available”. Select it to start the update manager, close powerTWO and follow
the instructions. After the download and install completes, start powerTWO. It may request a
windows restart. Sorry, but that shouldn’t happen too often.

Now connect the USB cable to your computer and to the mini USB plug on the front of the
powerONE (there is another plug at rear, but that one is ODBII). You don’t need a +12 (Vbatt)
source yet. powerONE is happy on USB power.

Win7 may just register the powerONE as an unspecified device. In that case go to;
Control Panel > Devices and Printers and you’ll see it as “Unspecified”’.

Right click on it and select Install from that menu and it will bring up this wizard.
XP and Vista will go directly to the wizard.

Found New Hardware Wizard

Welcome to the Found New
Hardware Wizard

YWindowves will search for current and updated software by
looking aon your compter, on the hardware inztallation CO, ar an
the ‘Windows Update "Web site [with pour permizgion).

Fiead our privacy policy

Can Windows connect to Windows pdate to search for
software?

(3 Wes, thiz time only

{7 Yes, now and every time | connect a device

Click. Mest to continue.

Hest » l[ Cancel

Now, the last steps in the installation:

e Windows will now go through the install wizard for USB devices
e Select No, not this time

e Select Install from a list ......



e Seclect Search from the best driver in these locations and browse to
C:\program files\ Enbedded Spaces Inc\powerTW O.
o On Windows 7, use C:\Program Files (x86)\... instead
e It will install the powerONE as a com port
e The next time you attempt to use the powerONE, powerTWO will tell you if it needs to
download any information for the powerONE device to your host PC
e Select the Tools> Options pulldown
o Select the Deszgn tab and choose degrees F or C.
o Select the General tab and Re-open last files at Startup; this option ensures that any
designs you last had open are opened again whenever powerTWO starts.
o Change anything else to taste but leave Searvh and Events alone unless directed there
by Customer Service.

Picking up updates

Whenever a new update is available, powerTWO will find it and request permission to install it, just

as above.

Starting a new design

This is unusual. There is always some sample that’s worth renaming and editing, but just pull down
File>New and you have a new, untitled design. File>SaveAs will get you to the standard Windows
dialogue to name and place your new .pox file.



Importing an existing design

File>Open will take you to the Windows open procedure. Just browse to your .pox directory.

Open

Loak in: |@ DatasheetPox V| 0 ? 9 [~

Y Sy
L ; } 1L datasheet_1.pox

ky Recent 5 datasheet_Z.pox

Documents @datasheet_&pnx

= @datasheet_‘?.pnx

I— Edatasheet_ﬂld.pox
Desktop @shntl PO

shot3, pox
\ Eshot“r.pox
by D ocuments
AE4
-
File name: |datasheet_1 po hd | [ Qpen l
tdy W ebwark

Places Files of type: ||:|DwerTW'D configuration filez [, pox) v| [ Cancel l




Editing a design

The Start tab takes you to a list of the presently Open Designs. This is like a Windows list. It also has a
list of the Recent Designs for quick access to your other work-in-progress.
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powerTWO Release Notes

powerONE and powerTWO beta page

1.1.1201.1.1191.1.1181.1.1171.1.1161.1.1151.1.114 1.1.113
1.1.1121.1.1111.1.1101.1.1091.1.1081.1.107 1.1.106 1.1.105
datazhest_2 - -

datazheet_3 1.1.104 1.1.103
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Connections

A displayed design, like the one on the cover, is ready to edit. If the window size needed to hold the
design is getting out-of-hand, use the [zew pulldown to scale it, or put up with window scrolling.

The object-creation tools are displayed on the standard toolbar and are grayed-out when that class of
objects has been used-up. They are also presented at a right mouse-click. A cursor-hover (just let
the mouse-cursor sit over the tool icon for a couple of seconds) identifies each tool. There is only
one each of the CAN (OBDII) and RPM inputs, 8 IOs and 12 LEDs.



. The RPM input is configured to the number of steps you want to measure and the
number of pulses that will be seen at the input for each engine revolution. An ECU will put
out 1 pulse. The ignition primary of 4-cycle engine will put out the (cylinder count + 2)

pulses.
User
o @ Users can be
o Inputs
= Analog
Measures the input voltage. Used mainly for gauge values.
= TFrequency
Much like RPM but measuring Hz (cycles/sec). Several types of modern
sensors put out a frequency instead of a voltage.
= Interval
Very like frequency input, but for slow things that require timing.
= Sense
These are logic levels. In a 12V system they will default to > 8V for a High
and < 4V for a low. You always have them at Vbatt or ground anyway.
o Outputs

= Control
Same as the sense input, but used to drive relays. A low output will pull
current through a relay and a high won’t.

= PWM entry
This switches a Pulsewidth Modulated (PWM) output waveform on and off.
A weird example would be a buzzer tone on and off.

* PWM table
This varies a PWM output according to an input or computed value to
control the speed of a DC motor. Water pumps, fans and wiper controls are

all normal uses.

The rest are:

e Logic-handling blocks & AND, | OR and X XOR

. ﬁ Switches which allow any internal inputs to be set High or Low.
(equivalent to I1Os seeing +12 or ground)

. @ Timers, configurable as
o Delay which just passes the input state to the output after the period expires
o One-shot which goes true when triggered and false after the period expire



o Retriggerable which is similar to one-shot but its period is set each time a trigger is
input, so the on-time is prolonged.
e Complex functions like
o MinMax which can store the high or low of an input or internal value
o Count which can be used to keep track of gear selection or a rotary-knob input
and to select logic according to the present value.

Objects may be explored with mouse-hover and may be reconfigured by double-click on the object.

Object configuration faults are marked by a red flag and the configuration fault is revealed by a
mouse-hover. A yellow flag on the RPM object means that the powerONE will simulate a sweeping
rpm input if it detects zero rpm at the real input.

Objects are interconnected by drawing a line between connection points with the pointer tool.
powerTWO will refuse connections of non-matching types, but an output may be connected to an
unlimited number of matching inputs. Inputs are generally singular, but the exception is the logic
blocks which will accept up to 8 inputs.

Value outputs (marked v) connect only to value inputs (also marked v), which is reasonable.
Step Value outputs (marked s) connect to StepValue or Preset Inputs (also marked s)

Logic (marked ) outputs connect to:

e Logic inputs (marked I)

e Led inputs (marked I)

e Led blink inputs (marked b)
e Opverride inputs (marked o)

e Disable inputs (marked d)

e C(Clear inputs (marked c)

e Enable inputs (marked e)

e Count up inputs (marked +)

e Count down inputs (marked -)



Saving and testing (downloading) a design
A design is saved with the normal File > Save, Save As, or Save A/l pulldowns.

If any objects are marked with a red-flag, they must be corrected before test. Reconnect the
powerONE and select download from the top toolbar.

;‘_ﬁ Download datasheet 1 ...

Check powerOME devicelz] to download to
Serial Murmnber Status

powerJME %1.1.3_536306764 (01.1.2_B6314343) o055413 Meeds dovwnload

Download LCancel

If there are no powerONEs registered on the download window:

e Check that the USB connection is good. The powerONE should show a small, blinking-
green led about an inch behind the front panel at the right-hand side. Windows should make
the Windows noises when you disconnect and reconnect the cable. Close and re-open the
download window to see if the powerONE was found after reconnecting the cable.

o If you see the “Found New Hardware Wizard”, go back to the bottom of the
“Download and Install ...” section.

o If you still have no registered powerONE when you reconnect, contact product
support
http://www.emspace.com -> Contact -> Support

or Skype embedded spaces

e Select download. powerTWO will build powerONE configuration and download it.
If powerTWO detects a configuration problem it will decline the download and direct you to
the misconfigured element.
e Your powerONE is now running the program. You can just make your connections and go.
But we recommend:
o Use the target monitor. It’s quick and saves a lot of measuring
o Make a test setup if you have any fragile equipment to connect
o Don’t let any input states go untested.
Use some kind of voltage source to simulate over-temperatures and under-


http://www.emspace.com/
callto:embeddedspaces

pressures. Use a frequency source, like an audio output from your PC to simulate
over-revs.

e Start the target monitor from the top toolbar.

;'_"ﬂ' Monitor datasheet_1 ...

Check powerONE device to maonitor )
Serial Murnber Statuz

powerJME ¥1.1.3 536306764 [[1.1.2_6E6314843) 20155413 Ready ...

Rate [mS) [ Monitor

You may select an update rate between 5 and 100 ms but your eyes can only register about
30 ms. An elderly PC may prefer the slowest (100 ms) setting, which is workable, it just
misses some quick, transient events.
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The monitored states are:

Input Sense

e High |
e Low |__
Value
e Any object internal value is indicated in a value box
(see RPM here)
Connection
e True— blue
e TFalse — black
LED
e On —LED colour [yellow or red|
e Off — black
Output Control
e High | (yellow)
e Low | (yellow)
e Unmonitored (black)



Updating the powerONE bios

If you receive notice from product support to update the powerONE flash, they will provide the
update as a .csum file. Pull down /Tools > Adpanced > Flash/ from the tools menu, browse to the
place you stored the file, select the powerONE on COM xx and then Flash.

lash application to powerONE device

Application image

File: POWETONE. CELIM
Browse

Check, powerlOME device to flash Senal Mumber Status

powerOMNE on COM11 80155413 Bootloader 1.3

Do niot power off unit before flashing iz complete.




